Apache-Logo

Instalando o Apache no CentOS 7

Dando continuidade ao tutorial de instalação do LAMP no CentOS, hoje vamos ver como instalar o Apache. No tutorial anterior, vimos como instalar o MariaDB.

O Apache é o mais bem-sucedido servidor web livre. Ele representa cerca de 47.20% dos servidores ativos no mundo. Além disso, é a principal tecnologia da Apache Software Foundation.

Para instalar o Apache execute o comando abaixo.

yum install httpd

Ao término da instalação deverá ser exibida uma mensagem de concluído.

Para iniciar o serviço do Apache execute o comando abaixo:

systemctl start httpd.service

Após iniciado basta digitar no seu browser localhost e você deverá ver uma página com a seguinte mensagem:

Testing 123.. page

Como nosso intuito é colocar o Worpress nesse servidor, vamos instalar alguns pacotes adicionais.

Execute o comando abaixo para instalar os pacotes necessários para a hospedagem do Worpress nesse servidor:

yum install php php-mysql php-gd

Após isto reinicie o Apache com o comando abaixo:

systemctl restart httpd.service

Para adicionar o Apache na inicialização do sistema digite o comando abaixo:

systemctl enable httpd.service

A instalação do Apache em si é bem simples. Na próxima parte iremos ver como configurar o WordPress.

Até a próxima.

  • Madeira Junior

    Vendo esses comandos “systemctl restart httpd.service”

    Tenho saudades do bom e velho “service restart httpd”

    • Thiago Roberth

      Justamente, e juntamente com isso tambem o “ntsysv”.

  • Madeira Junior

    Vendo esses comandos “systemctl restart httpd.service”

    Tenho saudades do bom e velho “service restart httpd”

    • Thiago Roberth

      Justamente, e juntamente com isso tambem o “ntsysv”.

  • Madeira Junior

    Vendo esses comandos “systemctl restart httpd.service”

    Tenho saudades do bom e velho “service restart httpd”

    • Thiago Roberth

      Justamente, e juntamente com isso tambem o “ntsysv”.

  • Maikon David

    Alguém me ajuda!? Tudo que tento instalar da isso :c

    • Alexandre Vicenzi

      Qual distro e qual versão? O problema parece que não está achando o pacote nos repositórios, talvez tenha que adicionar algum que esteja faltando.

      • Maikon David

        centOS6-32bit

      • Maikon David

        instalei os repositórios rpm forge e continuo tendo o mesmo erro .-.
        Não sei se esse seria o repositório certo, mas se puder dá uma ajudinha agradeceria….

        • Alexandre Vicenzi

          Sim, é esse.

          # wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm
          # rpm -Uvh rpmforge-release-0.5.2-2.el6.rf.i686.rpm

          Qualquer coisa veja se este link lhe ajuda.

          • Maikon David

            Fiz todo o processo do link que mandou, e continua dando a mesmo mensagem, dizendo que não há nenhum pacote httpd.. .-. Algo mais que eu possa fazer?

          • Alexandre Vicenzi

            Sim, “yum search apache” ou “yum search httpd”, pode ser que o pacote esteja com outro nome.

          • Maikon David

            Qual eu devo instalar? Desculpa ser tão leigo e chato, mas é que realmente preciso…

          • Alexandre Vicenzi

            Depende do SO o Apache se chama httpd. É a mesma coisa com nomes diferentes. Quase igual ao MariaDB e o MySQL, no fundo é a mesma coisa.

          • Maikon David

            Então posso usar qualquer um desses da imagem que também vai dá certo? Eu preciso dele para rodar .php

          • Alexandre Vicenzi

            Pode sim, faz um setup de Nginx com FPM 🙂

          • Alexandre Vicenzi

            Agora que vi que tinha uma imagem acima, nenhum desses serve. Os pacotes não estão aparecendo, tente rodar uma atualização na lista de pacotes do yum.

          • Maikon David

            Não deu certo… .-.

          • Alexandre Vicenzi

            Mas depende o que você quer fazer também, eu prefiro usar o Nginx ao invés do Apache.

  • Maikon David

    Alguém me ajuda!? Tudo que tento instalar da isso :c

    • Alexandre Vicenzi

      Qual distro e qual versão? O problema parece que não está achando o pacote nos repositórios, talvez tenha que adicionar algum que esteja faltando.

      • Maikon David

        centOS6-32bit

      • Maikon David

        instalei os repositórios rpm forge e continuo tendo o mesmo erro .-.
        Não sei se esse seria o repositório certo, mas se puder dá uma ajudinha agradeceria….

        • Alexandre Vicenzi

          Sim, é esse.

          # wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm
          # rpm -Uvh rpmforge-release-0.5.2-2.el6.rf.i686.rpm

          Qualquer coisa veja se este link lhe ajuda.

          • Maikon David

            Fiz todo o processo do link que mandou, e continua dando a mesmo mensagem, dizendo que não há nenhum pacote httpd.. .-. Algo mais que eu possa fazer?

          • Alexandre Vicenzi

            Sim, “yum search apache” ou “yum search httpd”, pode ser que o pacote esteja com outro nome.

          • Maikon David

            Qual eu devo instalar? Desculpa ser tão leigo e chato, mas é que realmente preciso…

          • Alexandre Vicenzi

            Depende do SO o Apache se chama httpd. É a mesma coisa com nomes diferentes. Quase igual ao MariaDB e o MySQL, no fundo é a mesma coisa.

          • Maikon David

            Então posso usar qualquer um desses da imagem que também vai dá certo? Eu preciso dele para rodar .php

          • Alexandre Vicenzi

            Pode sim, faz um setup de Nginx com FPM 🙂

          • Alexandre Vicenzi

            Agora que vi que tinha uma imagem acima, nenhum desses serve. Os pacotes não estão aparecendo, tente rodar uma atualização na lista de pacotes do yum.

          • Maikon David

            Não deu certo… .-.

          • Alexandre Vicenzi

            Mas depende o que você quer fazer também, eu prefiro usar o Nginx ao invés do Apache.

  • Maikon David

    Alguém me ajuda!? Tudo que tento instalar da isso :c

    • Alexandre Vicenzi

      Qual distro e qual versão? O problema parece que não está achando o pacote nos repositórios, talvez tenha que adicionar algum que esteja faltando.

      • Maikon David

        centOS6-32bit

      • Maikon David

        instalei os repositórios rpm forge e continuo tendo o mesmo erro .-.
        Não sei se esse seria o repositório certo, mas se puder dá uma ajudinha agradeceria….

        • Alexandre Vicenzi

          Sim, é esse.

          # wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm
          # rpm -Uvh rpmforge-release-0.5.2-2.el6.rf.i686.rpm

          Qualquer coisa veja se este link lhe ajuda.

          • Maikon David

            Fiz todo o processo do link que mandou, e continua dando a mesmo mensagem, dizendo que não há nenhum pacote httpd.. .-. Algo mais que eu possa fazer?

          • Alexandre Vicenzi

            Sim, “yum search apache” ou “yum search httpd”, pode ser que o pacote esteja com outro nome.

          • Maikon David

            Qual eu devo instalar? Desculpa ser tão leigo e chato, mas é que realmente preciso…

          • Alexandre Vicenzi

            Depende do SO o Apache se chama httpd. É a mesma coisa com nomes diferentes. Quase igual ao MariaDB e o MySQL, no fundo é a mesma coisa.

          • Maikon David

            Então posso usar qualquer um desses da imagem que também vai dá certo? Eu preciso dele para rodar .php

          • Alexandre Vicenzi

            Pode sim, faz um setup de Nginx com FPM 🙂

          • Alexandre Vicenzi

            Agora que vi que tinha uma imagem acima, nenhum desses serve. Os pacotes não estão aparecendo, tente rodar uma atualização na lista de pacotes do yum.

          • Maikon David

            Não deu certo… .-.

          • Alexandre Vicenzi

            Mas depende o que você quer fazer também, eu prefiro usar o Nginx ao invés do Apache.